現在的時間是 週六 9月 26, 2020 8:27 pm
所有顯示的時間為 UTC + 8 小時

請問JELLYFIN如何開啟硬體加速

Who doesn't love third-party apps? Get together and talk about them here.

版主: bennetliu

請問JELLYFIN如何開啟硬體加速

文章echoli08 » 週一 7月 06, 2020 2:51 pm

請問版上的大大們小弟最近買了AS3102TV2
因想在自己家裡架媒體伺服器,好外出時也可以看看影片
陸續試了PLEX,EMBY以及JELLYFIN...最後決定使用JELLYFIN(因為他免費)
但串流時發現常常都會卡頓卡頓的,因此就想去調整設定看能不能解決
但有關於如何開啟硬體加速的設定不是很清楚,
是只要把硬體加速選擇VAAPI後並打勾起用硬體架速就可以了,還是要有其他的設定呢?
因這是小弟第一次使用NAS,所以不是很清楚該如何做
VAAPI.jpg
VAAPI.jpg (83.38 KiB) 被瀏覽 286 次
echoli08
 
文章: 3
註冊時間: 週一 7月 06, 2020 1:41 pm

Re: 請問JELLYFIN如何開啟硬體加速

文章echoli08 » 週二 7月 07, 2020 8:19 am

開啟硬體加速的問題解決了....
不過新的問題是....透過Jellyfin去串流播放不順的問題
一開始我以為是cpu資源滿載或網路速度不夠(家裡網路是HINET 100M/40M)
所以才會想透過硬體加速的方式來做壓縮
但測試後發現看起來問題不是出在這上面
當開始串流時影片都會先卡個20~30秒,然後播放3~4秒後又卡個20~30秒
看了快十分鐘連個片頭版權宣告都沒看完(眼神死
但同樣的片子用emby做串流時即使不開啟硬體加速(要付費訂閱才能開)
基本上也能順暢播放....
實在是不懂問題出在哪
echoli08
 
文章: 3
註冊時間: 週一 7月 06, 2020 1:41 pm

Re: 請問JELLYFIN如何開啟硬體加速

文章lensin1 » 週二 7月 07, 2020 8:00 pm

我今天也試了一下jellyfin, 設定其實很簡單。我在AS5304T以及AS7004T 上面試。我發現如果播一般的1080p, 都可以播的動。但是如果播Hevc, 4k, 那CPU的使用率就非常非常高,幾乎到百分之百。即使用 Jellyfin 裡面所謂的硬體加速,但是並沒有感覺到有差別,因為CPU幾乎百分之百,所以就會卡頓。

但是如果在AS5304T 上面用Looksgood,播放4K,HEVC 是沒有問題的,還蠻順的。只不過介面是沒有Jellyfin好看. 如果你下載的影片是有 dts/dolby, 那你另外要在論壇上找一下第三方貢獻的audio patch 才可以播。

你的機種是AS3102T v2, cpu 是比較舊的然後也只有雙核而已,所以我想在使用jellyfin 的時候, CPU使用率一定是非常高的,也因此才會卡頓。

我建議你使用Looksgood,然後影片下載的最好不要是4K,1080就可以了,AS3102T 真的是不夠力的。不然就是要付費試試看Emby 或者是Plex 了。
lensin1
 
文章: 806
註冊時間: 週三 12月 04, 2013 2:59 pm

Re: 請問JELLYFIN如何開啟硬體加速

文章echoli08 » 週三 7月 08, 2020 1:30 pm

感謝您的回覆,在用jellyfin以及emby串流時我有一併監看資源使用率
看的影片編碼確實是HEVC 1080P
開啟串流前使用率大概是36~40%
使用emby串流時CPU使用率會上升到70%左右
使用Jellyfin 不開啟硬體加速時會滿載到99%,開啟硬體加速時則會降到60~70%左右
如果單就cpu使用率來看有沒開硬體解碼應該還是有差的,只是不管怎樣影片就還是跑不動(眼神死
目前只先放棄,晚上回家後來試看看原廠的lookgood看看...
echoli08
 
文章: 3
註冊時間: 週一 7月 06, 2020 1:41 pm

回到 Developer's Corner

  • 不能 在這個版面發表主題
    不能 在這個版面回覆主題
    不能 在這個版面編輯您的文章
    不能 在這個版面刪除您的文章
    不能 在這個版面上傳附加檔案
  • 誰在線上

    正在瀏覽這個版面的使用者:沒有註冊會員 和 1 位訪客

cron